Performance issue in US
Incident Report for Vincere
Resolved
This incident has been resolved
Posted Mar 03, 2021 - 03:57 UTC
Identified
The issue has been identified and a fix is being implemented to resolve the issue
Posted Mar 03, 2021 - 03:38 UTC
Investigating
We are currently investigation the performance issue that impact users in US regions
Posted Mar 03, 2021 - 03:08 UTC
This incident affected: Vincere Core (US).